Cloud Infrastructure Maintenance
Scheduled for Nov 21, 09:00 - 17:00 CET
Update
We will be undergoing scheduled maintenance during this time.
Posted Nov 14, 2024 - 11:30 CET
Scheduled
We will be undergoing scheduled maintenance during this time.
Posted Nov 12, 2024 - 14:23 CET
This scheduled maintenance affects: EHMP Enterprise (EHMP Enterprise mobile, EHMP Enterprise web) and EHMP Professional (EHMP Professional mobile, EHMP Professional web).